Bluetooth connection dropping

Audio, Navigation, Electronic Faults and Fixes
User avatar
PhilB
Posts: 5975
Joined: Mon Aug 17, 2015 12:57 pm
Location: South Buckinghamshire

Re: Bluetooth connection dropping

Post by PhilB » Wed Mar 13, 2019 8:58 am

People need to remember that not everybody is conversant with pie, jam tart or whatever the version is called .
How about we stick to numerical version which everybody can understand without having to look up what it means.
Thanks.
MY20 Evoque P300 HSE.
Previously: 2015 XE S 340, British Racing Green. 2017 XE S 380, Carpathian grey.


User avatar
billvega
Posts: 510
Joined: Sun Sep 03, 2017 3:14 pm
Location: Essex

Re: Bluetooth connection dropping

Post by billvega » Wed Mar 13, 2019 10:22 am

PhilB wrote:
Wed Mar 13, 2019 8:58 am
People need to remember that not everybody is conversant with pie, jam tart or whatever the version is called .
How about we stick to numerical version which everybody can understand without having to look up what it means.
Thanks.
Good point, I had to look it up myself :lol: Android 9 I believe.
XE R Sport 180, MY18, Corris Grey, Black Pack/Venoms, Cold Climate, 40/20/40, Parking Pack, 10-Way Seats & 4-Way Lumbar.


User avatar
BLZeebub
Posts: 115
Joined: Fri Mar 02, 2018 7:38 am
Location: Kent

Re: Bluetooth connection dropping

Post by BLZeebub » Fri Mar 15, 2019 8:03 am

I've got this one now aswell. My Galaxy Note 8 has been fine all the time it was running Android 8 but last week it finally got Android 9 and the issues started. I had a bit of a play yesterday and deleted and then re-connected. I then sat there and watched the car settings...

The bluetooth in the car unticked by itself and the options went grey. Then after about 10s, the tick re-appeared and the options turned white. The phone and car connected and held for a few seconds and then the bluetooth in the car unticked and the cycle repeated.

Interestingly, after about 5 cycles i was about to give up when i noticed the phone was asking confirmation of access to the contacts, despite me having allowed connections when i first re-connected.

This morning, it connected, disconnected, re-connected and then appeared to stay stable.

I'll see what happens over the next few days...

B-)
MY17 All Black R-Sport 180D AWD with some gadgets. B-)


User avatar
billvega
Posts: 510
Joined: Sun Sep 03, 2017 3:14 pm
Location: Essex

Re: Bluetooth connection dropping

Post by billvega » Fri Mar 15, 2019 8:22 am

BLZeebub wrote:
Fri Mar 15, 2019 8:03 am
I've got this one now aswell. My Galaxy Note 8 has been fine all the time it was running Android 8 but last week it finally got Android 9 and the issues started. I had a bit of a play yesterday and deleted and then re-connected. I then sat there and watched the car settings...

The bluetooth in the car unticked by itself and the options went grey. Then after about 10s, the tick re-appeared and the options turned white. The phone and car connected and held for a few seconds and then the bluetooth in the car unticked and the cycle repeated.

Interestingly, after about 5 cycles i was about to give up when i noticed the phone was asking confirmation of access to the contacts, despite me having allowed connections when i first re-connected.

This morning, it connected, disconnected, re-connected and then appeared to stay stable.

I'll see what happens over the next few days...

B-)
I can tell you now mate, after a week of using it the bluetooth cycles until eventualy it becomes stable. Sometimes it takes once or twice sometimes five or six! It seems to connect ok but as soon as you select bluetooth as source for audio it freaks out.

On a plus note, the audio seems to be louder now than previously and better quality.
XE R Sport 180, MY18, Corris Grey, Black Pack/Venoms, Cold Climate, 40/20/40, Parking Pack, 10-Way Seats & 4-Way Lumbar.


User avatar
BLZeebub
Posts: 115
Joined: Fri Mar 02, 2018 7:38 am
Location: Kent

Re: Bluetooth connection dropping

Post by BLZeebub » Fri Mar 15, 2019 8:33 am

billvega wrote:
Fri Mar 15, 2019 8:22 am


I can tell you now mate, after a week of using it the bluetooth cycles until eventualy it becomes stable. Sometimes it takes once or twice sometimes five or six! It seems to connect ok but as soon as you select bluetooth as source for audio it freaks out.

On a plus note, the audio seems to be louder now than previously and better quality.
Oh joy, i only use the phone on BT so that may be why it appears stable.

Although, the fact the car BT appears to cycle and not the phone does point in the direction of JLR. That said i guess the phone could be crashing the car side but i suspect it's a change in the way bluetooth works that the car doesn't like and they certainly won't want to put any resources into it so we will have the eternal finger pointing exercise.

B-(
MY17 All Black R-Sport 180D AWD with some gadgets. B-)


User avatar
Fredaikis
Posts: 2
Joined: Wed Mar 27, 2019 12:52 am
Location: Stockholm

Re: Bluetooth connection dropping

Post by Fredaikis » Wed Mar 27, 2019 12:56 am

I just upgraded from a iPhone 7 to a Samsung Galaxy S10+ and starting having this issue.
Also, my colleague is experiencing the same issue on my car with his Samsung Note 8. (happened since the android update)

So after some testing I have found out that if you disconnect the voice, music works fine without interruptions, but when both are online, it seems to crash the car's bluetooth system. (if you look at the bluetooth setting, you can actually see it completely disable -> enable)

I will try to fiddle with the bluetooth options under the Development Options to see if downgrading any versions / settings could solve the issue.


User avatar
lolord
Posts: 24
Joined: Wed Sep 14, 2016 11:14 pm
Location: Lille(FR)

Re: Bluetooth connection dropping

Post by lolord » Sun Apr 28, 2019 6:00 pm

billvega wrote:
Mon Mar 11, 2019 10:15 am
Just upgraded to the Samsung S10+. Previously had the S8+ with zero connection problems.

The S10 keeps dropping connection. Does this for about 3 cycles then becomes stable.

Madness :evil:
Hi,
I have the S8+ (model SM-G9550). No problem with Android 8 until it was updated a month ago to Android 9, which drives me crazy.
Unfortunately, the latest update does not solve the problem at this time ("Build Number : G9550ZHU3DSD3 , Android version : Pie(Android 9) , Release Date : 2019-04-26, Security patch level : 2019-04-01") : http://doc.samsungmobile.com/sm-g9550/tgy/doc.html

So S8+ or S10+ , i think there is no difference ;)
ImageXE 20d 180 R-Sport BVA8 BlueFireImage
10Way Seats+4way Lumbar+Heated front seats|Advantage pack|Navigation|Privacy Glass|Air quality sensing|Auto dimming rear view mirror


BruceTheQuail
Posts: 72
Joined: Mon Mar 25, 2019 3:39 am
Location: Gold Coast

Re: Bluetooth connection dropping

Post by BruceTheQuail » Sun Apr 28, 2019 9:23 pm

Mine has been working again from about 25 April, although I have only only used the phone in the car on a few days since then. It had been driving me postal, on about the 24th it was dropping out in about 1 minute intervals in a 10 minute call, which was the worst that it had been.

The improvement seemed to have been after other updates were installed.
2016 XE 25T R-sport in IRR
Coming - 2020 XE P300 HSE R-dynamic in Firenze
Daily driver - F Type V6 S in IRR with many chav accoutrements


User avatar
billvega
Posts: 510
Joined: Sun Sep 03, 2017 3:14 pm
Location: Essex

Re: Bluetooth connection dropping

Post by billvega » Sun Apr 28, 2019 11:19 pm

If when you get in your car you just leave it to connect, then after 5 to 10 minutes you will be able to use it. It seems to cycle a few times before becoming stable. But if you try using it before 5 minutes it will keep dropping until you again leave it for at least 5 minutes :roll:
XE R Sport 180, MY18, Corris Grey, Black Pack/Venoms, Cold Climate, 40/20/40, Parking Pack, 10-Way Seats & 4-Way Lumbar.


BruceTheQuail
Posts: 72
Joined: Mon Mar 25, 2019 3:39 am
Location: Gold Coast

Re: Bluetooth connection dropping

Post by BruceTheQuail » Mon Apr 29, 2019 12:07 am

That had been my experience as well until late last week. Now it kicks in immediately and no dropouts, even if I was on a call before starting the car. Fingers crossed for the drive home today, I will see whether it works.

I did install the "Force Pair" app, but I dont think it helped.
2016 XE 25T R-sport in IRR
Coming - 2020 XE P300 HSE R-dynamic in Firenze
Daily driver - F Type V6 S in IRR with many chav accoutrements


Post Reply

Return to “Electronics and In Car Entertainment”