USB music playback problem

Audio, Navigation, Electronic Faults and Fixes
pozbaird
Posts: 9
Joined: Sat Oct 06, 2018 6:26 pm
Location: Glasgow

USB music playback problem

Post by pozbaird » Sat Oct 06, 2018 6:59 pm

Wondering if anyone has encountered this same issue... I got a new XE 2019 R Sport model three weeks ago, and my previous car was a VW Golf, in which a SanDisk 32gb USB with about 17gb of music on it, played without issue for over three years. No matter if your journey was five minutes, five hours, or if the Golf was inactive for two weeks while you were on holiday, every time you returned to the car, the USB resumed playback at the exact spot you were at the last time you were in the car.

Using the same stick in the Jaguar has been nothing but problematic. The main issue being the system never resumes from the spot you were at. If you were listening to a particular artist you had about 80 songs by, and had listened to 3 of them before stopping at your local petrol station for five minutes, when starting the car again, the system plays the radio, and when you navigate back to USB, starts playing at the first track alphabetically on the stick. If you drive for an hour or so and get through 15 or 16 songs by your chosen artist - same thing. Annoyingly, it initially plays a radio station, and then never, ever, picks up where you left it. Same thing overnight. You might have been enjoying 25 songs by whoever is your choice, and simply wanted to pick up where you left off the next day - nope, system plays the radio on start up, and loses the place you were last listening to.

The car was in for a software update, no joy, same problem persists. The dealership are currently waiting for Jaguar technical dept to get back to them with a fix. I know it isn’t the end of the world, but it is annoying that a 36k car’s system cannot do what the one in the VW Golf did with ease for three years. With no CD player in the car, I need the USB to work as it did in the Golf.

I tried erasing the USB, making sure it was FAT 32 formatted, and tried simply having the MP3 files in one lump on the USB without arranging them in artist-specific folders. No joy, same issue. Every time you press the ignition button, the radio comes on, and after navigating your way back to the USB, you are immediately back to ‘song one’, which in my case happens to be ‘12 Fingers’ by Young The Giant, as that is alphabetically the first song...and a song I am rapidly becoming sick and tired of hearing the opening bars of, every time I fire up the engine.

Any input or info’ greatly appreciated!


User avatar
Pongo
Posts: 158
Joined: Mon Aug 27, 2018 8:16 pm
Location: Worcestershire

Re: USB music playback problem

Post by Pongo » Sat Oct 06, 2018 8:04 pm

Is it a 3.0 USB ? Maybe try a different USB stick ?

I'm not techie, but l recently managed to burn some cd's onto a 3.0 USB using a 10 year old laptop and this works a treat in my XE. Picking up where it left off etc.
2016 XE-S 340


User avatar
Pete321
Posts: 39
Joined: Sat Jul 28, 2018 11:39 am
Location: Basildon

Re: USB music playback problem

Post by Pete321 » Sat Oct 06, 2018 9:58 pm

I use a 64gb Sandisk usb with 320kbps mp3 files in files by artist. Not had any problems, playback starts where it left off on shuffle.
MY18 XE 2.0d 180 R Sport Black Edition


pozbaird
Posts: 9
Joined: Sat Oct 06, 2018 6:26 pm
Location: Glasgow

Re: USB music playback problem

Post by pozbaird » Sat Oct 06, 2018 10:39 pm

It is a USB 3 stick, and the same one that worked without missing a beat in the VW Golf. The same stick also works perfectly in my wife’s VW Polo. I’ll give the dealership a chance to get a response from Jaguar technical and get back to me. No point in buying a new USB stick yet. If Jaguar suggest that, then fine, I’ll give it a go.

Thanks for the responses so far, appreciate it. It would appear that my issue is not common, as other people have no issue with the USB playback acting the way it does in my XE. Also, the staff at the dealership who drive Jags say the system in their car is fine.

I’ll report back!


User avatar
147daytona
Posts: 771
Joined: Fri Jul 08, 2016 8:50 pm
Location: Lowestoft, UK

Re: USB music playback problem

Post by 147daytona » Sat Oct 06, 2018 10:55 pm

I also have this problem but have found a work-around that seems to cure the problem in my car, but I'm not saying it will work for you.

Before I turn off the ignition, I change the music source to Radio, then when I restart the car obviously the radio starts up, but if I then change the source back to USB, it starts playing again from where it last finished.

A bit of a faff but it seems to work in mine.

Incidentally, another issue mine has is if I'm listening to DAB and turn the ignition off, I instantly lose reception and have silence, but listening to any other source and turning the ignition off, the audio continues until I open the door to get out!
MY17 240 R-Sport, IRR, Black Pack, Park Pack, Cold Climate Pack, 19" Twin 5 Spokes, Jet/Red Interior, 10 Way + Lumbar, Split Rear Seat, ICT Pro, Illuminated Tread Plates, Configurable Mood Lighting, Alloy Paddles & Pedals, Homelink, Spare Wheel.


mdem
Posts: 92
Joined: Fri Dec 01, 2017 8:29 am
Location: Blackburn, Victoria, Australia

Re: USB music playback problem

Post by mdem » Sat Oct 06, 2018 11:00 pm

Hi,

I assume that you have the ICT Pro (10" screen). I have almost the same issue as you and am using a 128gb Sandisk USB 3.0 Cruzer. The music files are mostly Apple Lossless format with a smattering of mp3 files as well.

It worked perfectly, as you described in your Golf, until the ICT Pro software was upgraded a few months ago. The upgrade gave me the reading of text messages and improved the overall stability of the system, however I also got this annoying music playing issue.

Mine tends to be a bit random though. I can stop for an hour or so and it starts playing where it left off. I can stop for 5 minutes and it starts at the same song as it always starts at when this happens (Lovely Linda by Paul McCartney) and the shuffle is off. So I put the shuffle back on and tap for the next track and we are back to shuffling all songs again. Then sometimes the radio will be on instead of the USB. At least then it remembers the last station that it was on!! Then when I switch to USB it may start playing Lovely Linda or it may remember where it was.

It's a total lucky dip really.

The only thing that I can conclude about the radio coming on rather than the USB is that at times the system is slow to recognise the USB on start up so it reverts to the radio.

Also, I have found that if I am playing just one LP rather than shuffling all music, it does remember where it left off. Although the radio on start up still happens at times.

I did get some advice from this forum some time back that if you turn the audio off before turning the car off, then when you turn it back on again after the next start up it will work fine every time. I think that this worked but to be honest, never got into the routine of doing this and have just put up with hearing the first few bars of Lovely Linda on most start ups.

I'll be interested to hear what your dealer says about this.
2017 XE S, Dark Sapphire, Propellor wheels, Adaptive cruise control, sunroof, climate seats, ICT Pro.


pozbaird
Posts: 9
Joined: Sat Oct 06, 2018 6:26 pm
Location: Glasgow

Re: USB music playback problem

Post by pozbaird » Sat Oct 06, 2018 11:24 pm

Again, thanks for latest replies. As a control expeiment, I’ll use the same USB stick but will try the ‘switch the radio on’ before exiting the car trick and see if it works. Can’t hurt to try and is only a quick press on the steering wheel button...if I remember to do it.

I did try the ‘switch infotainment off’ before exitng thing, but that didn’t work.

It seems a lot of flaffing about in a 36k car, when my wife’s 12k VW Polo handles a USB stick the same way my Golf did - you just shove the stick in and choose the music you want, and every time you get back into the car and turn the ignition on, the thing plays from where you left it.


BOBCDP
Posts: 341
Joined: Wed Jun 22, 2016 8:51 pm
Location: Vale of Glamorgan

Re: USB music playback problem

Post by BOBCDP » Sun Oct 07, 2018 9:53 am

posbaird you didn't say if it was the ICT Pro or the standard system. Mine is standard and a 32gb card and always starts up where it left off either on USB or radio.

The only thing I have never worked out is how USB decides what it's going to play and in what order it does it. All tracks are in the root directory and recorded as "Artist - track name.mp3" and I would Have expected it would play them in alphabetical order. For the most part it does do that but then odd trackS are out of sync for some reason. It must pick up something embedded in the track I suppose.
MY16 2015 R-Sport 180d, Auto, Yulong White,


JiggyJag
Posts: 772
Joined: Wed Jun 01, 2016 11:00 pm
Location: Sunny South Wales

Re: USB music playback problem

Post by JiggyJag » Sun Oct 07, 2018 10:27 am

BOBCDP wrote:
Sun Oct 07, 2018 9:53 am
posbaird you didn't say if it was the ICT Pro or the standard system. Mine is standard and a 32gb card and always starts up where it left off either on USB or radio.

The only thing I have never worked out is how USB decides what it's going to play and in what order it does it. All tracks are in the root directory and recorded as "Artist - track name.mp3" and I would Have expected it would play them in alphabetical order. For the most part it does do that but then odd trackS are out of sync for some reason. It must pick up something embedded in the track I suppose.
Mine's the standard system and the folders are by artist and then album. Not had any issues with playing out of order.
Main issue i had is that it always repeated the album when ending the last track of that album, all others cars I've had moved to the next album.
I got round it by creating playlists for each artist.
Curr: MY18 XE Portfolio 250 RWD, Loire blue / Oyster, parking pack, folding mirrors, spare wheel, splash guards
Prev: MY17 XE Prestige 180 Auto, Odyssey red / Latte, parking pack, heated screen, pano roof, folding mirrors, spare wheel, splash guards


User avatar
PhilB
Posts: 5058
Joined: Mon Aug 17, 2015 12:57 pm
Location: South Buckinghamshire

Re: USB music playback problem

Post by PhilB » Sun Oct 07, 2018 10:29 am

Thinking back to my previous one with the standard ICT, there were issues getting tracks to play in album order and not alphabetically.
I seem to remember going into it and tapping on "files" then "albums" and it would play fine.

The thing to remember with either system is that it takes a little while for the USB to come up on the "source" list.
Radio is there straight away so if it was left playing off the usb on switch off then it may fry it's brain to start with until it's got it's act together.
XE S 380, Storm grey Pics Black venoms/black pack, 18 ways, BSM, 40/20/40, ICTPro 380, parking pack, spare wheel.
Previous: 2015 XE S 340, British Racing Green.


Post Reply

Return to “Electronics and In Car Entertainment”