Android broken bluetooth again?

Audio, Navigation, Electronic Faults and Fixes
StevenC
Posts: 7
Joined: Wed Feb 20, 2019 9:04 am
Location: Surrey

Android broken bluetooth again?

Post by StevenC » Thu Feb 21, 2019 9:24 am

I've just picked up my XE 2.0 Portfolio on the 16th of this month, but the bluetooth issues are driving me MAD. It appeared to be fine all Saturday, but then I updated the software on my phone on the Saturday night, and now I'm plagued by constant disconnects. I've got a Samsung S9+, Android Version 9, and the issue sounds very much like what happened in an update of Android 7.

Just want to know if anyone else has upgraded to Android 9 and is having this issue?

Steve


jonet
Posts: 6
Joined: Sat Feb 02, 2019 8:29 pm
Location: Shropshire

Re: Android broken bluetooth again?

Post by jonet » Thu Feb 21, 2019 9:54 am

Hi,
yes exactly the same, had no problems at all with my S9 until the update to pie. Now totally unusable, disconnects/re-connects all the time - can't make calls in the car now. Does the same in our other car, so definitely the phone. Just waiting now for a new update to fix it!
MY18 2018 Jaguar XE 180 Diesel Auto R-Sport Santorini Black, Black Pack, 19" Venom Alloys, Park Pack, Cold Climate Pack.


StevenC
Posts: 7
Joined: Wed Feb 20, 2019 9:04 am
Location: Surrey

Re: Android broken bluetooth again?

Post by StevenC » Thu Feb 21, 2019 10:31 am

It seems us Jag owners aren't the only ones to suffer...

https://eu.community.samsung.com/t5/Gal ... 531/page/2

Multiple issues all across the Android scope stating problems with Android Pie and Bluetooth! UAT testing at its finest...


User avatar
Nevyn
Posts: 445
Joined: Sun Jun 12, 2016 7:31 pm
Location: Northamptonshire

Re: Android broken bluetooth again?

Post by Nevyn » Thu Feb 21, 2019 2:30 pm

There'a post in another thread with a fix that might work until you can get an update. Sadly I didn't have that option under developer settings on my Sony phone, but you might be luckier.
jpsmyth wrote:
Sat Feb 17, 2018 7:35 am
Hi,

I've got a Nexus 5X and had exactly the same issue. Looking on an Android forum its almost certainly the updates not the car.... One solution that seems to have worked for many people is to go into the developer settings on your phone;

- Go to settings.
- Then System
- Then "About Phone"
- On "Build number" tap it 7 times and you enter "developer mode"
- Go back a screen to "System" and you should see "{ } Developer options" - tap that
- Scroll down to "Bluetooth AVRCP Version" - firstly try changing it to 1.3 (that seems to be the most compatible)
- Now reboot the phone and try in the car.
- If you still have problems try the different versions of AVRCP.

- If you still have problems make sure the next setting down "Bluetooth Audio Codec" is set to "SBC" as this can also cause an issue.

Hope that helps.
2016 180d Portfolio Auto. Ammonite Grey + Light Oyster. 19" Star 5 Twin-Spokes + lots of toys...
http://www.xeforums.co.uk/viewtopic.php?f=10&t=2888


Rob Wright
Posts: 143
Joined: Tue Nov 06, 2018 9:26 pm
Location: West coast of Scotland

Re: Android broken bluetooth again?

Post by Rob Wright » Thu Feb 21, 2019 2:36 pm

I don't seem to have any issues with my Android 9 mobile. Bluetooth is set to AVRCP1. 3 and audio codec set to default.
Corris Grey 25D AWD R-Sport


StevenC
Posts: 7
Joined: Wed Feb 20, 2019 9:04 am
Location: Surrey

Re: Android broken bluetooth again?

Post by StevenC » Thu Feb 21, 2019 2:57 pm

I've changed the settings back down to 1.3 and that did not fix it unfortunately.

I think it may just be an issue with the Samsung release of Pie, or something similar across certain brands.

It's a question of bothering to downgrade to 8.X or waiting until Samsung release a fix... Annoying!


User avatar
147daytona
Posts: 972
Joined: Fri Jul 08, 2016 8:50 pm
Location: Lowestoft, UK

Re: Android broken bluetooth again?

Post by 147daytona » Thu Feb 21, 2019 6:49 pm

I have no issues with my S7 Edge. I've got Android 8.0.0 with Samsung Experience 9.0. AVRCP is set to 1.4 (with 1.5 and 1.6 as options), and SBC is selected for the Bluetooth Audio Codec.

If I see an update to Android 9.0, I think I'll decline it.
MY17 240 R-Sport, IRR, Black Pack, Park Pack, Cold Climate Pack, 19" Twin 5 Spokes, Jet/Red Interior, 10 Way + Lumbar, Split Rear Seat, ICT Pro, Illuminated Tread Plates, Configurable Mood Lighting, Alloy Paddles & Pedals, Homelink, Spare Wheel.


carrke66
Posts: 1
Joined: Fri Mar 01, 2019 10:23 pm
Location: United States

Re: Android broken bluetooth again?

Post by carrke66 » Fri Mar 01, 2019 10:25 pm

Same issue with my S9+. Connects to my wife's Volvo XC60 with no issues, but won't to the Jaguar. My work phone (Samsung S8 works perfectly) but the S9+ won't do calls. Holds a connection perfectly if only streaming music, but try to connect for phone and the system goes nuts.


StevenC
Posts: 7
Joined: Wed Feb 20, 2019 9:04 am
Location: Surrey

Re: Android broken bluetooth again?

Post by StevenC » Tue Mar 05, 2019 11:19 am

Can confirm, it's definitely the upgrade to 9.0.0 Android that causes it to go bust.

Downgraded my phone back to 8.0.0 (a surprisingly easy process for anyone that wants too) and now the Bluetooth works absolutely spot on.


User avatar
Vespa
Posts: 4805
Joined: Sun Oct 11, 2015 10:50 am
Location: North West UK

Re: Android broken bluetooth again?

Post by Vespa » Tue Mar 05, 2019 4:09 pm

StevenC wrote:
Tue Mar 05, 2019 11:19 am
Can confirm, it's definitely the upgrade to 9.0.0 Android that causes it to go bust.

Downgraded my phone back to 8.0.0 (a surprisingly easy process for anyone that wants too) and now the Bluetooth works absolutely spot on.
How is that done please?
180 diesel XE R Sport, with many extras :D


Post Reply

Return to “Electronics and In Car Entertainment”