Brake Light/Indicator Not Working

Audio, Navigation, Electronic Faults and Fixes
Post Reply
User avatar
tranxhdr
Posts: 118
Joined: Fri Jun 17, 2016 6:04 am
Location: Los Angeles, California

Brake Light/Indicator Not Working

Post by tranxhdr » Sun Aug 12, 2018 1:16 am

Not sure if it's just a bad bulb or wiring fault but the rear right side brake lights are not working. Both bulbs. On the dash, the indicator blinks twice as fast as it normally should. When I turn on the hazard lights, both indicators blink at normal speed on the dash but no light on the rear end on the right side.

Any idea specifically what type of problem this is?

20180811_170110.png

2017 Jaguar XE 25t Prestige, Vision Package, Polaris White, Black 19" Venoms, Black Interior


User avatar
Bazzamf
Posts: 300
Joined: Thu Aug 31, 2017 4:33 pm
Location: Bucks

Re: Brake Light/Indicator Not Working

Post by Bazzamf » Sun Aug 12, 2018 7:57 am

It's normally a bulb that goes rather than a problem with wiring.
Bazzamf - XE 200 Ingenium Portfolio in Santorini Black


User avatar
PhilB
Posts: 5051
Joined: Mon Aug 17, 2015 12:57 pm
Location: South Buckinghamshire

Re: Brake Light/Indicator Not Working

Post by PhilB » Sun Aug 12, 2018 8:20 am

It could be one of several things.
People have had issues with the multiplug and contacts.
I would remove the cluster (the right side is tricky due to the fusebox making things a bit tight to undo the plastic retaining nut)
Check all the bulbs are fully pushed in and working properly and check the multiplug, cleaning the contacts if needed.
XE S 380, Storm grey Pics Black venoms/black pack, 18 ways, BSM, 40/20/40, ICTPro 380, parking pack, spare wheel.
Previous: 2015 XE S 340, British Racing Green.


capese21
Posts: 150
Joined: Wed Dec 30, 2015 7:34 pm

Re: Brake Light/Indicator Not Working

Post by capese21 » Sun Aug 12, 2018 3:47 pm

On the dash, the indicator blinks twice as fast as it normally should. When I turn on the hazard lights, both indicators blink at normal speed
This is normal to show if the bulb has blown but hazard lights work at normal speed regardless. As said check for blown / loose bulbs and loose connecter.

Post up what fixes it!!


User avatar
tranxhdr
Posts: 118
Joined: Fri Jun 17, 2016 6:04 am
Location: Los Angeles, California

Re: Brake Light/Indicator Not Working

Post by tranxhdr » Sun Aug 12, 2018 4:33 pm

Turned out it was burnt out bulbs. I replaced both of them and it's working again.
2017 Jaguar XE 25t Prestige, Vision Package, Polaris White, Black 19" Venoms, Black Interior


User avatar
tranxhdr
Posts: 118
Joined: Fri Jun 17, 2016 6:04 am
Location: Los Angeles, California

Re: Brake Light/Indicator Not Working

Post by tranxhdr » Mon Aug 13, 2018 5:35 am

Seems I spoke too soon. The bulbs aren't working again. Took the car out for an evening drive, used the right indicator and it began blinking fast again. I'm just going to take it to a local mechanic and let them check it out. Although my XE is still under warranty, the latest appointment available with the dealership service is not until two weeks from today... :shock:
2017 Jaguar XE 25t Prestige, Vision Package, Polaris White, Black 19" Venoms, Black Interior


Post Reply

Return to “Electronics and In Car Entertainment”